Firmware Help

Discussion in 'Firmware Mods' started by Keith, Nov 25, 2017.

  1. Keith

    Keith Member

    Joined:
    Nov 5, 2017
    Messages:
    125
    Likes Received:
    0
    Hello,

    I'm having issues with a older Deltaprintr KS laser cut plywood version. With help from Denys I have got the printer up and running but we think the firmware version is wrong or I need to modify it in some way.
    I'm using https://github.com/tkurbad/Marlin/tree/RC_Deltaprintr I basically flash the firmware change the height to match and also my Jhead. First my screen looked like:
    [​IMG]

    note the heat bed and Maxtemp error.

    Denys screen looks like this[​IMG]

    His shows the FRS bed.

    My question is how to I change the firmware or can someone suggest what I have been doing wrong when flashing. I must be missing something

    thanks.
    Keith
     
  2. Keith

    Keith Member

    Joined:
    Nov 5, 2017
    Messages:
    125
    Likes Received:
    0
  3. Keith

    Keith Member

    Joined:
    Nov 5, 2017
    Messages:
    125
    Likes Received:
    0
    so I had a thought that maybe if I set the thermistor to 0 (Zero) then it would not see the heat bed. because it sees the FRS sensors Now and showed the graphic on the LDC but also showed the heat bed. So:) I changed it #define TEMP_SENSOR_BED 1 to 0

    #define TEMP_SENSOR_0 11
    #define TEMP_SENSOR_1 0
    #define TEMP_SENSOR_2 0
    #define TEMP_SENSOR_3 0
    #define TEMP_SENSOR_BED 0

    // This makes temp sensor 1 a redundant sensor for sensor 0. If the temperatures difference between these sensors is to high the print will be aborted.
    //#define TEMP_SENSOR_1_AS_REDUNDANT
    #define MAX_REDUNDANT_TEMP_SENSOR_DIFF 10

    it worked..... my screen looks like yours and runs the bed leveling as it should. so the original modification to the firmware was enabeling the FRS_BED_leveling then changing the
    #define TEMP_SENSOR_BED 1 to 0

    // FSR sensors connected to thermistor input of the second extruder and mounted underneath
    // the print bed of the Deltaprintr
    #define FSR_BED_LEVELING

    It works.... I just need to test the print.
     
  4. Keith

    Keith Member

    Joined:
    Nov 5, 2017
    Messages:
    125
    Likes Received:
    0
    I'm still having firmware issues I have not being able to get the printer to print correctly. looks mostly like a Z height issue if anyone one has suggestions that would be great!

    plowing.jpg
     
Loading...

Share This Page